How to deploy WMS 5


<div id="fb-root"></div>
<script>(function(d, s, id) {
  var js, fjs = d.getElementsByTagName(s)[0];
  if (d.getElementById(id)) return;
  js = d.createElement(s); js.id = id;
  js.src = 'https://connect.facebook.net/en_US/sdk.js#xfbml=1&version=v2.11';
  fjs.parentNode.insertBefore(js, fjs);
}(document, 'script', 'facebook-jssdk'));</script>



<span class="page-title-pdf">Deploying WMS5 on Hardware, Virtual and Cloud PBXs</span>



<div class="fb-like" data-href="https://confluence.wildix.com/x/WYKEB" data-layout="button_count" data-action="recommend" data-size="large" data-show-faces="true" data-share="true"></div>


 <div class="lang-box-pdf">
	<div>
		<div class="google-lang">
			<div id="google_translate_element">
			</div>
			<script type="text/javascript">
					function googleTranslateElementInit() {
						new google.translate.TranslateElement({pageLanguage: 'en', includedLanguages: 'de,es,fr,it,nl', autoDisplay: false}, 'google_translate_element');
						}
			</script>
			<script type="text/javascript" src="//translate.google.com/translate_a/element.js?cb=googleTranslateElementInit"></script>
		</div>
		
		<div class="pdf-button">
			<a href="https://confluence.wildix.com/spaces/flyingpdf/pdfpageexport.action?pageId=75792985" alt="Convert to .pdf" title="Convert to .pdf"><img src="https://confluence.wildix.com/download/attachments/14549012/pdf-button-download-wildix-documentation.png"></a>
		</div>
	</div>
</div>


Deploy WMS 5 on Hardware, Virtual and Cloud PBXs.

Created: July 2020

Updated: November 2020

Permalink: https://confluence.wildix.com/x/WYKEB

If your WMS version is lower than WMS4, first upgrade your PBX to WMS4, please follow the document: Deploying WMS 4.0 on Hardware, Virtual, Cloud PBXs

Upgrade to WMS 5 is supported on: Per User PBXs updated to the latest WMS 4 version with monthly, yearly or 5 year subscriptions. Lifetime per user systems bought  onwards.

Upgrade to WMS 5 is NOT SUPPORTED on: Per Service PBXs and Lifetime Per User PBXs , licenses for these PBXs must be regenerated.

How to update an unsupported system to WMS5: 

Install or upgrade VM PBX

Upgrade a VM PBX from WMS4 to WMS5

  1. Update the PBX to the latest WMS4 version (using repository rel40)
  2. Update the PBX to the first WMS5 version (using repository rel50)

Upgrade of VM PBXs running WMS 3.XX or lower is not supported. Follow the guide Deploying WMS 4.0 on Hardware, Virtual, Cloud PBXs to install a VM PBX running WMS4. 

Update of VM PBXs with Lifetime licenses is not supported. Follow the guide Deploying WMS 4.0 on Hardware, Virtual, Cloud PBXs to move your PBX to Cloud if you wish to use WMS5.

Install a new WMS5 VM PBX 

Requirements

Any kind of VM hypervisor capable of importing OVF/OVA templates for deploying, is supported.

Recommended requirement for VM systems:
2vCPU, 4GB -> PBX managing up to 1000 users
4vCPU, 8GB -> PBX managing up to 5000 users
8vCPU, 16GB -> PBX managing up to 10000 users

Requirements may differ depending on the system usage (i.e. additional integrations, burst load, etc).

Deployment

ovftool WMS_5.01_x64_20200710.ova WMS_5.01_x64_20201113.ovf 


ovftool --maxVirtualHardwareVersion=11 wms_5_01_x64_20201113.ova wms_5_01_x64_20201113_v11.ova


Once the VM is installed, follow PBX Licensing and Activation Admin Guide (chapter PBX Activation) to activate your PBX and add user licenses.


Note: If you install the system using Hyper-V, download VHD archive from here: https://files.wildix.com/images/wms5/WMS_5.01_x64_20201113_vhd.zip.




Upgrade HW PBX 

Requirements

Upgrade a HW PBX from WMS4 to WMS5

  1. Update the PBX to the latest WMS4 version (using repository rel40)
  2. Update the PBX to the first WMS5 version (using repository rel50)

Upgrade of HW PBXs running WMS 3.XX or lower is not supported. Follow the guide Deploying WMS 4.0 on Hardware, Virtual, Cloud PBXs to install WMS4 on your HW PBX first, before upgrading it to WMS5.

Update of HW PBXs with Lifetime licenses is not supported. Follow the guide Deploying WMS 4.0 on Hardware, Virtual, Cloud PBXs to move your PBX to Cloud if you wish to use WMS5.

Activate or upgrade Cloud PBX

Add a new Cloud PBX


Note: Wait for approximately 3 minutes before proceeding. Your PBX will be activated. 

Upgrade your Cloud PBX 

Requirement:

Upgrade of Hardware PBXs running WMS 3.XX or lower is not supported. Follow the guide Deploying WMS 4.0 on Hardware, Virtual, Cloud PBXs to migrate your Cloud PBX to WMS4 first, before upgrading it to WMS5.

To upgrade your newly created or existing Cloud PBX to WMS 5 version, proceed with the following steps:

  1. Update the PBX to the latest WMS4 version (using repository rel40)
  2. Update the PBX to the first WMS5 version (using repository rel50)


<div class="fb-like" data-href="https://confluence.wildix.com/x/WYKEB" data-layout="button_count" data-action="recommend" data-size="large" data-show-faces="true" data-share="true"></div>



<div class="ask-question">
		<div class="text-before-buttons">
			<span style="font-size: 24px; text-align: center;">Not finding the help you need?</span><br>
Join the Facebook group to ask a question!
		</div>
<div class="fb-buttons">
<span style="align: center;"><a href="https://www.facebook.com/groups/wildixtechwizards" target="_blank"><img src="https://manuals.wildix.com/wp-content/uploads/2017/03/facebook_tech-wizards.png" alt="facebook_tech-wizards" width="282" height="80" align="center"/></a></span></div>
	</div>